Attenzione: pericolo di malware

ATTENZIONE: Ho trovato un’attacco a questo sito.

Il pericolo tuttavia sembra risolto.

Venivano colpiti i file tipici di wordpress: index.php default.php (index.php rinominato su wordpress per host windows, file di configurazione per flatpress) fp-includes/core/core.wp-default-filters.php (insomma, quello col nome più simile).

L’attacco è stato descritto su questo sito esterno.

Io uso però flatpress, perciò è un po’ diverso.

Comunque sappiate che il malware aggiungeva alla fine delle pagine un codice javascript. Cosa faccia non lo so ma comunque mi secca.

Io ho cambiato le mie password.

Comunque il malware sembra non aver avuto conseguenze perché il programmatore che l’ha programmato è stato stupido!

Io avrei aggiunto if(!function_exists('security_update')), invece non l’ha messo e così il PHP mi restituisce l’errore che è dichiarata più volte! Meglio così

In teoria il pericolo dovrebbe essere scampato e non voglio creare allarmismi.

In ogni caso io non sono responsabile di nessun danno creato alla macchina di qualcun’altro!